Fuel or ignition problem

General Excel discussions. You may also post Eclat and Elite information here. If there is enough call I will set up new categories or even a new BB for them.

Moderator: Board Moderators

User avatar
shaunw
Senior Poster
Posts: 1206
Joined: Sat Jul 10, 2010 19:19
Model: Excel SE
Colour: pacific blue maghide
Year: 1990
Location: Hants

Fuel or ignition problem

Post by shaunw »

Since moving house at the end of July I've only used the Excel a couple of times. the first time i took it out after moving a couple of months ago it ran fine but on pulling away after stopping at some traffic lights it hesitated almost to the point of stalling before clearing and running fine for the next 20 miles. I put it down to lack of use. Took it out again today and the car ran well for about 15 miles but on exiting a corner i put my foot down and it hesitated severely before very briefly cutting out, it then continued hesitating and any attemp to accelerate hard resulted in the car cutting out altogether , lifting the throttle brought it back to life but anything other than the feathering the throttle resulted in further cut outs. It then konked out at a roundabout and refused to start for a few minutes. When it did restart it ran really rough the rest of the way home with anything other than light throttle use resulting in violent jerking or complete cutting out. Tickover is as smooth as a babies bum. This was with the rev limiter disconnected so its definitely not the culprit. The rest of the ignition is in good shape having been renewed in the last few years. Im thinking that I may have dredged up some muck from the tank or the fuel pump ( which is original ) is playing up. I havent had a chance to look at it yet, anybody had similar symptoms?

Shaun

User avatar
Lotus-e-Clan
Senior Poster
Posts: 3967
Joined: Thu Nov 30, 2006 13:25
Model: Excel SE - EWP/Waterless!
Colour: Not Blue or Green
Year: 1989
Location: Swaledale

Re: Fuel or ignition problem

Post by Lotus-e-Clan »

Sounds exactly same pattern of events when my fuel pump was sticking - took me ages to diagnose. Responded for a while by hitting it. Now have a new electronic SU replacement (not cheap @ £120).

Aged pump is more likely to stick when left for a while ...so every aspect fits IMHO.
Peter K

User avatar
shaunw
Senior Poster
Posts: 1206
Joined: Sat Jul 10, 2010 19:19
Model: Excel SE
Colour: pacific blue maghide
Year: 1990
Location: Hants

Re: Fuel or ignition problem

Post by shaunw »

Thanks Peter, the fuel pump is the prime suspect!

Shaun

User avatar
amarshall
Moderator
Posts: 8282
Joined: Tue Nov 01, 2005 18:09
Model: SE
Colour: Monaco White
Year: 1990
Location: Darlington
Contact:

Re: Fuel or ignition problem

Post by amarshall »

Either fuel pump or a cheap riveted rotor arm breaking down.
https://www.lotusexcel.co.uk/
SORN - just say NO!

User avatar
shaunw
Senior Poster
Posts: 1206
Joined: Sat Jul 10, 2010 19:19
Model: Excel SE
Colour: pacific blue maghide
Year: 1990
Location: Hants

Re: Fuel or ignition problem

Post by shaunw »

amarshall wrote:Either fuel pump or a cheap riveted rotor arm breaking down.
Yes, i cant remember whether its a rivited one or not. ISTR it came for SJS. Well worth looking at.

Sirclip
Senior Poster
Posts: 243
Joined: Mon Apr 07, 2014 09:18
Model: Excel Celebration
Colour: Marque Lotus
Year: 1991
Location: Wiltshire

Re: Fuel or ignition problem

Post by Sirclip »

Hi Shaun,
My money would be on an ignition problem, as the symptoms you describe are very typical of a 'weak' spark, eg on wide openings of the throttle the spark is 'extinguished'. Hence it may well be the rotor arm, or something else related to the HT side of the coil.

User avatar
Hawaiis0
Senior Poster
Posts: 3206
Joined: Sun Jun 30, 2013 18:39
Model: Excel SA No 3
Colour: BRG
Year: 1986
Location: West Oxfordshire

Re: Fuel or ignition problem

Post by Hawaiis0 »

Pop the top off the carb chamber and look for shit. Mine had a bit of brown tarring which wiped away easily.
Umm! What to do next?

User avatar
Doc Si
Regular Poster
Posts: 172
Joined: Tue Nov 15, 2005 13:47
Model: 86 SE
Colour: RED
Year: 1986
Location: Lowestoft, Suffolk

Re: Fuel or ignition problem

Post by Doc Si »

When mine did similar it turned out to be the rotor arm as suggested above by AM

User avatar
shaunw
Senior Poster
Posts: 1206
Joined: Sat Jul 10, 2010 19:19
Model: Excel SE
Colour: pacific blue maghide
Year: 1990
Location: Hants

Re: Fuel or ignition problem

Post by shaunw »

Thanks for the advice guys. Rotor arms are cheap and easy so i'll start there.

Shaun

tonypoll
Senior Poster
Posts: 784
Joined: Sun Nov 13, 2005 19:27
Model: Excel SE
Colour: BRG
Year: 1992
Location: Hampshire/Surrey/Berkshire

Re: Fuel or ignition problem

Post by tonypoll »

Easy to look at the old pump's points and see if they are in poor condition.
If you go the fuel pump route you may want to fit an electronic conversion kit http://burlen.co.uk/electronic-pump-con ... -12-v.html, approx £60.
I had a similar problem many years ago, fitted this kit and it's been fine ever since.

Tony

Johnwindwood
Senior Poster
Posts: 443
Joined: Sat Mar 25, 2017 14:34
Model: 1984 Excel
Colour: Monaco White
Year: 1984
Location: walsall

Re: Fuel or ignition problem

Post by Johnwindwood »

tonypoll wrote:Easy to look at the old pump's points and see if they are in poor condition.
If you go the fuel pump route you may want to fit an electronic conversion kit http://burlen.co.uk/electronic-pump-con ... -12-v.html, approx £60.
I had a similar problem many years ago, fitted this kit and it's been fine ever since.

Tony
Tiny bit of a thread hijack (Sorry!) but how easy are these kits to fit Tony? Can it be done with pump in situ?
Kind regards

John

John Windwood

1984 Lotus Excel (1985 MY wide body)
1952 Austin Sheerline A125 Harold Radford Shooting Brake
1949 Austin Sheerline saloon (Parts car)
1997 BMW Z3 1.9

KevW
Senior Poster
Posts: 1575
Joined: Sat Jun 16, 2007 23:20
Model: Excel SE
Year: 1992
Location: Newcastle Upon Tyne, England

Re: Fuel or ignition problem

Post by KevW »

I'm very familiar with the symptoms of a non functioning pump due to my own forgetfulness and your description rings a bell with me Shaun. Maybe you pump is on it's way to failure although I agree a new rotor arm is the obvious first step to take. I bought a very nice quality red arm from Distributor Doctor online

I have a hidden fuel pump cut off switch on my Excel which I fitted mainly for times when I'm tinkering with the car with the ignition circuit live. The switch means I don't have to have the pump ticking away and flooding the carbs with petrol whilst I'm busy. The downside is that because I often forget to switch the pump circuit back on when I'm finished I end up starting the engine and driving off only for the engine to stutter to a halt. It will then often re-start but refuse to rev above tick over. It's surprising to me how well the engine will run without a pump. I've found it will start, idle smoothly and then allow me to get a couple of hundred yards down the road before it dies.

John, you need to take the pump off the car to work on it. Rather then convert I bought a new solid state pump from Lotusbits in 2008 and it's still going strong.
Kev W no.282

tonypoll
Senior Poster
Posts: 784
Joined: Sun Nov 13, 2005 19:27
Model: Excel SE
Colour: BRG
Year: 1992
Location: Hampshire/Surrey/Berkshire

Re: Fuel or ignition problem

Post by tonypoll »

Agreed. You need to remove the pump to fit the electronics kit. However, removal and fitting of the kit is quite easy.

User avatar
DavidOliver
Senior Poster
Posts: 478
Joined: Fri Nov 07, 2014 11:18
Model: Excel
Colour: Calypso Red
Year: 1985
Location: Malaga Spain

Re: Fuel or ignition problem

Post by DavidOliver »

I have just ordered a pump renovation kit, mainly to have a readily available fix here in Spain without
a 10 day delivery concern. Also this kit retains the original click-click telling you on engine start-up that the inmobiliser has been de-activated, the battery is up to strength , and if the starter does not chime in you go straight to it to find out why.
The electronic unit kit does not contain a new diaphragm which after 34 years in my car I think it deserves
retirement. Worthwhile adding in if you buy the electronic kit. (Unless of course the new diaphragm has slant eyes patronage). Also a good time to change the fuel filter.

Dave the cog.

User avatar
Lotus-e-Clan
Senior Poster
Posts: 3967
Joined: Thu Nov 30, 2006 13:25
Model: Excel SE - EWP/Waterless!
Colour: Not Blue or Green
Year: 1989
Location: Swaledale

Re: Fuel or ignition problem

Post by Lotus-e-Clan »

DavidOliver wrote:I have just ordered a pump renovation kit, mainly to have a readily available fix here in Spain without
a 10 day delivery concern. Also this kit retains the original click-click telling you on engine start-up that the inmobiliser has been de-activated, the battery is up to strength , and if the starter does not chime in you go straight to it to find out why.
The electronic unit kit does not contain a new diaphragm which after 34 years in my car I think it deserves
retirement. Worthwhile adding in if you buy the electronic kit. (Unless of course the new diaphragm has slant eyes patronage). Also a good time to change the fuel filter.

Dave the cog.
Hello Dave in warm Spain

The newreplacement electronic version of the SU pump that I bought from Lotus Bits does 'pulse' normally when you switch on the ignition. It's not only the points that gives you notice that the pump is working, battery on etc
Peter K

Post Reply