Excel indicator stalk 1984

Eclat or Excel parts for sale.

Moderator: Board Moderators

Post Reply
jpm6591
Junior Poster
Posts: 61
Joined: Fri Oct 05, 2007 12:32
Model: Lotus Excel
Colour: Green
Year: 1984
Location: Welwyn Garden City, Herts

Excel indicator stalk 1984

Post by jpm6591 »

Has anyone dismantled one of these?
https://www.johnrichardssurplus.co.uk/l ... 33768.html
Mine is relatively new, only a few years old and 240miles use. However the stalk will not stay in position in either Left or right positions. Works if I hold it in position. Bit wary of talking apart as I ventured down that path with wiper switch and watched as a small spring took off down the road, never to be seen again :-(

TIA Jim

User avatar
Alan_M
Senior Poster
Posts: 1099
Joined: Sat Aug 12, 2017 01:17
Model: Excel SE, Excel SA, Elan SE
Colour: Red, red, white
Location: South Wales

Re: Excel indicator stalk 1984

Post by Alan_M »

Are you sure the ring with the protrusion that cancels the indicators as you turn the wheel is correctly position and not sliding/jammed?

Pete Boole
Senior Poster
Posts: 3688
Joined: Tue Apr 04, 2006 21:28
Model: Elite
Colour: Monaco White
Year: 1974
Location: Nottingham

Re: Excel indicator stalk 1984

Post by Pete Boole »

Alan_M wrote:
Wed Feb 07, 2024 19:44
Are you sure the ring with the protrusion that cancels the indicators as you turn the wheel is correctly position and not sliding/jammed?
That's what I was going to say!

Pete

jpm6591
Junior Poster
Posts: 61
Joined: Fri Oct 05, 2007 12:32
Model: Lotus Excel
Colour: Green
Year: 1984
Location: Welwyn Garden City, Herts

Re: Excel indicator stalk 1984

Post by jpm6591 »

Ok,
Will check that. RH seems to hold, LH nothing at all.
Both were working fine last time I drove her.

Thanks

Jim

jpm6591
Junior Poster
Posts: 61
Joined: Fri Oct 05, 2007 12:32
Model: Lotus Excel
Colour: Green
Year: 1984
Location: Welwyn Garden City, Herts

Re: Excel indicator stalk 1984

Post by jpm6591 »

It is the stalk, as I removed it and only the RH side holds about 60% of the time. LH doesn't click in at all.
Can it be opened for fault finding?

TIA

Jim

Post Reply